Support System Unavailable
Incident Report for webmate
Resolved
The support system is back up, we identified a storage problem as the cause of the failure
Posted Apr 23, 2024 - 08:46 CEST
Investigating
Our support system is currently down, we're currently investigating that issue.
Posted Apr 23, 2024 - 08:26 CEST